您的位置:首页 > 其它

HDU-5536 Chip Factory(字典树)

2016-09-22 22:05 375 查看


Chip Factory

Time Limit: 18000/9000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 1888    Accepted Submission(s): 847


Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips
today, the i-th
chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

maxi,j,k(si+sj)⊕sk

which i,j,k are
three different integers between 1 and n.
And ⊕ is
symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

 

Input

The first line of input contains an integer T indicating
the total number of test cases.

The first line of each test case is an integer n,
indicating the number of chips produced today. The next line has n integers s1,s2,..,sn,
separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109

There are at most 10 testcases
with n>100

 

Output

For each test case, please output an integer indicating the checksum number in a line.

 

Sample Input

2
3
1 2 3
3
100 200 300

 

Sample Output

6
400

 

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

传送门:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1002&ojid=0&cid=11108&hide=0

题意:给出n个元素的序列,要求找出3个不同的元素使得(A+B)^C的值最大
题解:01字典树,用字典树保存每个元素二进制的每一位,枚举A和B,然后在字典树中去掉A,B,去找使得(A+B)^C值最大的C,维护答案的最大值

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 1e6 + 5;
struct node{
int nxt[2],v;
void init(){
memset(nxt,-1,sizeof(nxt));
v=0;
}
}L[maxn];
int a[1005],t1[32],t2[32],tot;
void add(int x){
int now=0,tmp;
for(int i=31;i>=0;i--){
tmp=(x>>i)&1;
if(L[now].nxt[tmp]==-1) {
L[++tot].init();
L[now].nxt[tmp]=tot;
}
now=L[now].nxt[tmp];
L[now].v++;
}
}
void sub(int x){
int now=0,tmp;
for(int i=31;i>=0;i--){
tmp=(x>>i)&1;
now=L[now].nxt[tmp];
L[now].v--;
}
}
int query(int x){
int now=0,tmp,ret=0;
for(int i=31;i>=0;i--){
tmp=!((x>>i)&1);
if(L[now].nxt[tmp]==-1||L[L[now].nxt[tmp]].v<=0) tmp=!tmp;
ret+=((((x>>i)&1)^tmp)<<i);
now=L[now].nxt[tmp];
}
return ret;
}
int main(){
int T,n;
//freopen("in.txt","r",stdin);
scanf("%d",&T);
while(T--){
tot=0;
L[tot].init();
scanf("%d",&n);
for(int i=0;i<n;i++) {
scanf("%d",&a[i]);
add(a[i]);
}
int ans=0;
for(int i=0;i<n;i++){
sub(a[i]);
for(int j=0;j<i;j++){
sub(a[j]);
ans=max(ans,query(a[i]+a[j]));
add(a[j]);
}
add(a[i]);
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: