您的位置:首页 > 编程语言 > C语言/C++

HDU 1130 How Many Trees?

2016-09-22 16:41 417 查看
[align=left]Problem Description[/align]
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node
with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?

 

[align=left]Input[/align]
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

 

[align=left]Output[/align]
You have to print a line in the output for each entry with the answer to the previous question.

 

[align=left]Sample Input[/align]

1
2
3

 

[align=left]Sample Output[/align]

1
2
5

 

[align=left]Source[/align]
UVA

 

[align=left]Recommend[/align]
Eddy   |   We have carefully selected several similar problems for you:  1131 1133 2067 1267 1100 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

#include<cstdio>

int n,a[101][101];

void findd()
{
a[1][1]=1;
for(int i=2;i<=100;i++) //乘4i-2除以i+1
{
int x=0,z=4*i-2;
for(int j=1;j<=100;j++)
{
a[i][j]=a[i-1][j]*z+x;
x=a[i][j]/10;a[i][j]%=10;
}
x=0,z=i+1;
for(int j=100;j>=1;j--)
{
int k=a[i][j];
a[i][j]=(x*10+k)/z;
x=(x*10+k)%z;
}
}
}

int main()
{
findd();
while(scanf("%d",&n)==1)
{
int i=n;
while(a
[i]==0) i--;
for(;i>=1;i--) printf("%d",a
[i]);printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息