您的位置:首页 > 其它

hdu 3709 Balanced Number (数位DP)

2016-09-22 10:56 232 查看
Problem Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It’s your job

to calculate the number of balanced numbers in a given range [x, y].

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2

0 9

7604 24324

Sample Output

10

897

*题意:找出区间内平衡数的个数,所谓的平衡数

平衡数的概念:数n以数n中的某个位为支点,每个位上的数权值为(数字xi*(posi - 支点的posi)),如果数n里有一个支点使得所有数权值之和为0那么她就是平衡数。比如4139,以3为支点,左边 = 4 * (4 - 2) + 1 * (3 - 2) = 9,右边 = 9 * (1 - 2) = -9,左边加右边为0,所以4139是平衡数。*

*思路:数位DP+记忆化搜索;对于以哪位为支点,我们可以枚举,但需要注意每一次枚举都有0,我们最后得到结果需要减去0的重复数量;

dp[i][j][k] i表示处理到的数位,j是支点,k是力矩和。但是要要把全是0的数排除*

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 dp[20][20][2000];
int b[20];
__int64 dfs(int len,int x,int pos,int flag)
{
if(len==0)
return x==0;
if(x<0)
return 0;
if(!flag&&dp[len][pos][x]!=-1)
return dp[len][pos][x];
__int64 ans=0;
int end=flag?b[len]:9;
for(int i=0;i<=end;i++)
{
ans+=dfs(len-1,x+(len-pos)*i,pos,flag&&i==end);
}
if(!flag)
dp[len][pos][x]=ans;
return ans;
}
__int64 solve(__int64 n)
{
int len=0;
while(n)
{
b[++len]=n%10;
n=n/10;
}
__int64 ans=0;
for(int i=1;i<=len;i++)
{
ans+=dfs(len,0,i,1);
}
return ans-len;
}
int main()
{
int t;
scanf("%d",&t);
memset(dp,-1,sizeof(dp));
while(t--)
{
__int64 n,m;
scanf("%I64d%I64d",&n,&m);
printf("%I64d\n",solve(m)-solve(n-1));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: