您的位置:首页 > 其它

HDU 1171 Big Event in HDU(背包)(母函数)

2016-09-21 22:41 381 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 36462    Accepted Submission(s): 12654


[align=left]Problem Description[/align]
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100
--corresponding number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee
that A is not less than B.

 

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

[align=left]Sample Output[/align]

20 10
40 40

 

[align=left]Author[/align]
lcy
 

题意:给你这些一些东西的价值和数量,让你将总价值分为两个数使其最为接近。

思路:

1.多重背包的题目,我们可以先求sum/2可以获得的最大价值。状态转移方程:dp[j]  = max ( dp[j], dp[j-v[i]] + v[i] )

//HDU 1171
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int dp[250005];
int v[5005];
int main()
{
int n,vv,t;
while((~scanf("%d",&n)&&n>0))
{
memset(dp,0,sizeof(dp));
memset(v,0,sizeof(v));
int sum = 0,num = 0;
for(int i = 1;i <= n;i++)
{
scanf("%d%d",&vv,&t);
sum += vv*t;
v[num++] = vv*t;
}

for(int i = 0;i < num;i++)
{
for(int j = sum/2;j >= v[i];j--)
{
dp[j] = max(dp[j],dp[j-v[i]]+v[i]);
}
}
cout<<sum-dp[sum/2]<<" "<<dp[sum/2]<<endl;
}
}

2.母函数

待搞懂
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: