您的位置:首页 > 其它

HDU - 2041 超级楼梯

2016-09-21 21:19 197 查看
题目:

Description

有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?

Input

输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。

Output

对于每个测试实例,请输出不同走法的数量

Sample Input

2
2
3


Sample Output

1
2


斐波那契

代码:

#include<iostream>
#include<stdio.h>
using namespace std;

long long list[50];

int main()
{
list[1] = 1;
list[2] = 2;
for (int i = 3; i < 50; i++)list[i] = list[i - 1] + list[i - 2];
int n, a;
cin >> n;
while (n--)
{
cin >> a;
cout << list[a-1] << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: