您的位置:首页 > 其它

poj2586 Y2K Accounting Bug 贪心

2016-09-21 20:22 453 查看
题目连接:http://poj.org/problem?id=2586

Y2K Accounting Bug

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13774 Accepted: 6972
Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how
many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost
sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000

Sample Output
116
28
300612
Deficit

题意:
说了一大堆,大意是一个公司在12个月中,或固定盈余s,或固定亏损d.

但记不得哪些月盈余,哪些月亏损,只能记得连续5个月的代数和总是亏损(<0为亏损),而一年中只有8个连续的5个月,分别为1~5,2~6,…,8~12

问全年是否可能盈利?若可能,输出可能最大盈利金额,否则输出“Deficit".
思路:贪心 

每连续5个月中,在保证这5个月经营之和为亏损的情况下,亏损的月数肯定应尽量往后选,盈利的月数应尽量往前选

实际上;只要讨论5种情况即可

实际上;只要讨论5种情况即可;(任一月固定盈余s,或固定亏损d).

SSSSDSSSSDSS   4s<d       保证“连续5个月必亏损”,每连续5个月种至少1个月D,

保证可能有全年最大盈余,每连续5个月中至多4个月S

SSSDDSSSDDSS   3s<2d      保证“连续5个月必亏损”,每连续5个月种至少2个月D,

保证可能有全年最大盈余,每连续5个月中至多3个月S

SSDDDSSDDDSS   2s<3d      保证“连续5个月必亏损”,每连续5个月种至少3个月D,

保证可能有全年最大盈余,每连续5个月中至多2个月S

SDDDDSDDDDSD   s<4d       保证“连续5个月必亏损”,每连续5个月种至少4个月D,

保证可能有全年最大盈余,每连续5个月中至多1个月S

DDDDDDDDDDDD   s>=4d      保证“连续5个月必亏损”,每连续5个月种至少5个月D,

每月亏损,此情况全年必亏损

要注意的是,前4种情况都仅仅是“可能有全年的盈余”,而不是“一定有全年的盈余”。

但是若果一旦有盈余,必定是最大盈余

代码:

#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional>
using namespace std;
const int maxn = 100000 + 10;

//贪心 尽量盈利 每个月要么亏损要么盈利 五个月统计一次时为亏损
//5678910 11 12每个月都统计
//1 2 3 4 5 6 7 8 9 10 11 12
//把盈利的月份放到前面 五个一个区间 以第一个区间为标准
int s, d;
int sum;
int main()
{
while (scanf("%d%d", &s, &d)!=EOF)
{
sum = 0;
if (d > 4 * s)
sum = 10 * s - 2 * d;//ssssd ssssd ss
else if (2 * d > 3 * s)
sum = 8 * s - 4 * d;//sssdd sssdd ss
else if (3 * d > 2 * s)
sum = 6 * s - 6 * d;//ssddd ssddd ss
else if (4 * d > s)
sum= 3 * s - 9 * d;//sdddd sdddd sd
else sum = -12 * d; //ddddd ddddd dd

if (sum > 0)
printf("%d\n", sum);
else
printf("Deficit\n");
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息