您的位置:首页 > 其它

poj 3723 Conscription(最小生成树)

2016-09-21 18:00 399 查看
Conscription

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11677 Accepted: 4124
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some
relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB.
Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.

The first line of each test case contains three integers, N, M and R.

Then R lines followed, each contains three integers xi, yi and di.

There is a blank line before each test case.

1 ≤ N, M ≤ 10000

0 ≤ R ≤ 50,000

0 ≤ xi < N

0 ≤ yi < M

0 < di < 10000

Output

For each test case output the answer in a single line.
Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output
71071
54223

Source
POJ Monthly Contest – 2009.04.05, windy7926778

男女都是从0开始,为了在一颗树上,可以在男兵的序号加上n,即从0-n, 0-m变成了0-m+n。每条边的权值是可以省去的费用,如过没有边,总费用是(m+n)*10000,现在可以将边的权值改成负值,这样就把最大权森林问题变成了最小生成树问题了。

Kruskal算法实现代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e5+5;
int n, m, r, k, pre[maxn];

struct node
{
int u, v, w;
node() {}
node(int uu, int vv, int ww): u(uu), v(vv), w(ww) {}
bool operator < (const node &a) const
{
return w < a.w;
}
}edge[maxn];

int Find(int x)
{
int r = x;
while(pre[r] != r) r = pre[r];
int i = x, j;
while(i != r)
{
j = pre[i];
pre[i] = r;
i = j;
}
return r;
}

bool join(int x, int y)
{
int a = Find(x);
int b = Find(y);
if(a != b)
{
pre[b] = a;
return true;
}
return false;
}

int main(void)
{
int t;
cin >> t;
while(t--)
{
k = 0;
scanf("%d%d%d", &n, &m, &r);
for(int i = 0; i < m+n; i++) pre[i] = i;
int R = r;
while(R--)
{
int u, v, w;
scanf("%d%d%d", &u, &v, &w);
v += n;
w = -w;
edge[k++] = node(u, v, w);
}
sort(edge, edge+r);
int ans = (n+m)*10000, count = 0;
for(int i = 0; i < r; i++)
{
if(join(edge[i].u, edge[i].v))
{
count++;
ans += edge[i].w;
}
if(count == n+m-1) break;
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  最小生成树 kruskal