您的位置:首页 > 编程语言 > C语言/C++

【杭电】2017 字符串统计(字符串有毒!)

2016-09-21 16:18 357 查看


字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 68924    Accepted Submission(s): 37846


Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

 

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

 

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

 

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

 

Sample Output

6
9

这题主要涉及gets()的应用界限吧,挺重要的。

#include<stdio.h>//字符串统计
#include<string.h>
int main()
{
int n;
char str[100];
while(EOF!=scanf("%d",&n))
{
getchar();
while(n--)//依次读取字符串
        {
int count=0,i=0;
gets(str);
while(str[i]!='\0')
{
if(str[i]>='0'&&str[i]<='9')//计算数字字符个数
count++;
i++;
}
printf("%d\n",count);
}
}
return 0;
}
或者是
#include<stdio.h>//字符串统计
#include<string.h>
int main()
{
int n;
char str[100];
while(EOF!=scanf("%d%*c",&n))
{
while(n--)//依次读取字符串
        {
int count=0[b],i=0;
gets(str);
while(str[i]!='\0')
{
if(str[i]>='0'&&str[i]<='9')//计算数字字符个数
count++;
i++;
}
printf("%d\n",count);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 杭电 vc 6