您的位置:首页 > 其它

HDU 5858 Hard problem(几何)

2016-09-21 15:42 357 查看

Hard problem

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 364    Accepted Submission(s): 271
[/b]

[align=left]Problem Description[/align]
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?



Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.

 

[align=left]Input[/align]
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

[align=left]Output[/align]
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

[align=left]Sample Input[/align]

1
1

 

[align=left]Sample Output[/align]

0.29

[align=left]Source[/align]
2016 Multi-University
Training Contest 10
推公式

以下AC代码:
#include<stdio.h>
#include<math.h>
double p=3.14159265358979323846;
int main()
{
int t;
double l;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&l);
double c=(double)sqrt(2.0)*5*1.0/8.0;
double angel=acos(c)*1.0/p*180.0;   ///小角度
double anglen=2*angel;
double sshanxing1=anglen*1.0*p*l*l/360;      ///小扇形
double ssanjiao1=sqrt(7*1.0/32*1.0)*5*sqrt(2.0)*l*l*1.0/8.0;   ///大三角
double s1=sshanxing1-ssanjiao1;
double angel2=acos((double)(-sqrt(2.0)*1.0/4.0));     ///大角度
angel2=angel2*1.0/p*180.0;
double ssanjiao2=sqrt(7*1.0/32*1.0)*sqrt(1.0/32.0)*l*l;     ///小三角
double angel3=360-angel2*2;
double sshanxing2=angel3*p*l*l*1.0/(360*4)*1.0;  ///大扇形
double s2=sshanxing2-ssanjiao2;
double result=2*(s2-s1);
printf("%.2lf\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: