您的位置:首页 > 其它

POJ 2689 Prime Distance

2016-09-20 20:35 337 查看
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number
that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers
that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair.
You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17


Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.


题目大意:给出一个区间[L,U],找出区间内,相邻距离最近的两个素数 和 相邻距离最远的两个素数。

1<=L<U<=2,147,483,647 区间长度不超过1,000,000。

即就是要筛选出[L,U]之间的素数

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#define MAX 50000+10
#define inf 999999999
using namespace std;
bool prime[60010];//WA在这里···60000防爆
long long primes[60010],cnt;//1~50000的素数
long long primess[1000000+10];
int maxn,minn;
void make_prime(){
int k=(int)sqrt(MAX);
for(int i=2;i<=k;i++){
if(prime[i])continue;
for(int j=i*i;j<=MAX;j+=i)
prime[j]=1;
}
for(int i=2;i<=MAX;i++)
if(!prime[i])primes[++cnt]=i;
}
long long start1,end1,start2,end2;
int main(){
make_prime();
long long m,n;
while(scanf("%lld%lld",&m,&n)!=EOF){// EOF防止TLE
if(m==1)m=2;
maxn=-inf;
minn=inf;
memset(primess,0,sizeof(primess));
//映射 小数=每个大数-m
for(long long i=1;i<=cnt;i++){//枚举每个小素数
long long l,r;
if(m%primes[i]==0)l=m/primes[i];//找出倍数
else l=m/primes[i]+1;
r=n/primes[i];
for(long long j=l;j<=r;j++)
if(j>1)primess[primes[i]*j-m]=1;//筛选大合数
}
long long sum=-1;//数组从0开始存
for(long long i=m;i<=n;i++)
if(primess[i-m]==0)primess[++sum]=i;
if(sum<1){
printf("There are no adjacent primes.\n");
continue;
}
for(int i=0;i<sum;i++){
long long k=primess[i+1]-primess[i];
if(k<minn){
minn=k;
start1=primess[i];
end1=primess[i+1];
}
if(k>maxn){
maxn=k;
start2=primess[i];
end2=primess[i+1];
}
}
printf("%lld,%lld are closest, %lld,%lld are most distant.\n",start1,end1,start2,end2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: