您的位置:首页 > 其它

POJ 3041 POJ 3041

2016-09-20 19:32 387 查看
A - Asteroids
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld
& %llu
Submit Status Practice POJ
3041

Appoint description: 
System Crawler  (Sep 18, 2016 9:26:04 PM)

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at
the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2


Sample Output

2


Hint

INPUT DETAILS: 

The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 

.X. 

.X. 

OUTPUT DETAILS: 

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

#include<stdio.h>
#include <vector>
#include <string.h>
#include<iostream>
#define max_V 1000
using namespace std;
int V;
vector<int> G[max_V];//图的邻接表
int match[max_V];//妹子是否被相亲
bool used[max_V];//不能嫁给自己
void add_edge(int u ,int v)//妹子u对帅哥v有暧昧关系
{
G[u].push_back(v);
G[v].push_back(u);
}
bool dfs(int v)//能上就上,不能上抢亲尽量上
{
used[v]=1;
for(int i=0;i<G[v].size();i++)
{
int u = G[v][i];
int w=match[u];
if(w<0||(!used[w]&&dfs(w)))
{
match[v]=u;
match[u]=v;
return 1;
}

}
return 0;
}
//最终告别单身的人数
int bi_match()
{
int res =0;
memset(match,-1,sizeof(match));
for(int v=0;v<V;v++)
{
if(match[v]<0)
{
memset(used,0,sizeof(used));
if(dfs(v))res++;
}
}
return res;
}
int main()
{
int n,k,a,b;
scanf("%d%d",&n,&k);
V=2*n;
for(int i=0;i<k;i++)
{
scanf("%d%d",&a,&b);
add_edge(a-1,n+b-1);

}
printf("%d\n",bi_match());
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: