您的位置:首页 > 其它

POJ 3660 图传递闭包

2016-09-19 22:06 423 查看
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5


Sample Output

2

floyd拓扑判断连通性,如果出度+入度=n-1则可判断排名。


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <stdlib.h>
#define N 105
using namespace std;
int n,m;
int g

;
int u,v;
void floyd()
{
for(int k = 1;k<=n;k++)
for(int i = 1;i<=n;i++)
for(int j = 1;j<=n;j++)
g[i][j] |= g[i][k]&&g[k][j];
}
int main()
{
//freopen("caicai.txt","r",stdin);
scanf("%d%d",&n,&m);
for(int i = 0;i<m;i++)
{
scanf("%d%d",&u,&v);
g[u][v] = 1;
}
floyd();
int ans = 0;
for(int i = 1;i<=n;i++)
{
int cnt = 0;
for(int j = 1;j<=n;j++)
{
if(i==j) continue;
if(g[i][j]||g[j][i])
cnt++;
}
if(cnt==n-1)
ans++;
}
cout<<ans<<endl;
return 0;
}


View Code


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: