您的位置:首页 > 其它

Codeforces Problem 712A Memory and Crow

2016-09-19 19:12 344 查看
Description

There are n integers
b1, b2, ..., bn written in a row. For all
i from 1 to
n, values ai are defined by the crows performing the following procedure:

The crow sets ai initially
0.
The crow then adds bi to
ai, subtracts
bi + 1, adds the
bi + 2 number, and so on until the
n'th number. Thus,
ai = bi - bi + 1 + bi + 2 - bi + 3....

Memory gives you the values a1, a2, ..., an, and he now wants you to find the initial numbers
b1, b2, ..., bn written in the row? Can you do it?

Input

The first line of the input contains a single integer n (2 ≤ n ≤ 100 000) — the number of integers written in the row.

The next line contains n, the
i'th of which is ai ( - 109 ≤ ai ≤ 109) —
the value of the i'th number.

Output

Print n integers corresponding to the sequence
b1, b2, ..., bn. It's guaranteed that the answer is unique and fits in 32-bit integer type.

Sample Input

Input
5
6 -4 8 -2 3


Output
2 4 6 1 3


Input
5
3 -2 -1 5 6


Output
1 -3 4 11 6


Sample Output

Hint

In the first sample test, the crows report the numbers
6, - 4, 8, - 2, and
3 when he starts at indices
1, 2, 3,
4 and 5 respectively. It is easy to check that the sequence
2 4
6 1 3 satisfies the reports. For example,
6 = 2 - 4 + 6 - 1 + 3, and  - 4 = 4 - 6 + 1 - 3.

In the second sample test, the sequence 1,
 - 3, 4, 11,
6 satisfies the reports. For example, 5 = 11 - 6 and
6 = 6.

#include<iostream>
using namespace std;
const int N=100100;
int main()
{
long long arr
;
int n;

cin >> n;

for(int i=0; i<n; i++)
{
cin >> arr[i];
}

for(int i=1; i<n; i++)
{
cout << arr[i]+arr[i-1] << " ";
}

cout << arr[n-1];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: