您的位置:首页 > 其它

深度优先搜索【POJ 1979】

2016-09-19 18:34 323 查看
Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31399 Accepted: 17128
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

 思路:深度优先搜索,即一路向前,直到走不通换条路继续走,直到遍历完所有

     因为要向4个不同的方向移动,用dx[4]和dy[4]两个数组来表示4个方向向量。这样通过一个循环就可以实现4方向移动的遍历

    为了防止已走过的黑块再次记入总数,每新走一块黑块,将其标志为'!'

#include<iostream>

using namespace std;

const int MAX_H = 20;//行
const int MAX_W = 20;//列
int dx[4] = {1,0,-1,0},dy[4] = {0,1,0,-1};//下右上左
int sum;

int dfs(char field[][MAX_W+1],int H,int W,int x,int y)
{
sum++;
for(int i = 0; i < 4; i++)
{
int nx = x + dx[i],ny = y + dy[i];
if(nx >= 0 && nx < H && ny >= 0 && ny < W && field[nx][ny] == '.')
{
//cout << '[' << nx << ',' << ny << ']' << "\n"; //遍历的详细过程
field[nx][ny] = '!';
dfs(field,H,W,nx,ny);
}
}
return sum;
}

void solve(char field[][MAX_W+1],int H,int W)
{
int res = 0;
for(int i = 0; i < H; i++)
{
for(int j = 0; j < W; j++)
{
if(field[i][j] == '@')//找到所站的起始黑块
{
//cout << i << ',' << j << "\n";
res = dfs(field,H,W,i,j);
cout << res << "\n";
return;
}
}
}
}

int main()
{
int H,W;
char field[MAX_H][MAX_W+1];

while(1)
{
cin >> W >> H;
if(H == 0 && W == 0)
break;
for(int i = 0; i < H; i++)
{
for(int j = 0; j < W; j++)
{
cin >> field[i][j];
}
}
sum = 0;//记得清0
solve(field,H,W);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: