您的位置:首页 > 其它

poj 2560 Freckles

2016-09-18 22:41 344 查看
Freckles

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 8364 Accepted: 3979

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.

Consider Dick’s back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

Input

The first line contains 0 < n <= 100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

Sample Input

3

1.0 1.0

2.0 2.0

2.0 4.0

Sample Output

3.41

【分析】

给n个点的二维坐标,将它们以直线连通且使边的总长最小…

裸的最小生成树啊

【代码】

//poj 2560
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
double ans;
int father[505];
int n,m,k,T,s,t;
struct point
{
double x,y;
}czy[505];
struct node
{
int l,r;
double v;
}a[250005];
inline bool comp(const node &p,const node &q) {return p.v<q.v;}
inline double calc(double x1,double y1,double x2,double y2)
{
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
inline int find(int x)
{
if(x!=father[x]) father[x]=find(father[x]);
return father[x];
}
int main()
{
int i,j;
k=ans=0;
scanf("%d",&n);
fo(i,1,n)
father[i]=i;
fo(i,1,n)
scanf("%lf%lf",&czy[i].x,&czy[i].y);
fo(i,1,n)
fo(j,1,i-1)
{
k++;
a[k].l=i;
a[k].r=j;
a[k].v=calc(czy[i].x,czy[i].y,czy[j].x,czy[j].y);
}
sort(a+1,a+k+1,comp);
fo(i,1,k)
if(find(a[i].l)!=find(a[i].r))
{
father[find(a[i].l)]=find(a[i].r);
ans+=a[i].v;
}
printf("%.2lf\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: