您的位置:首页 > 大数据 > 人工智能

hdu1702 ACboy needs your help again!(栈和队列

2016-09-18 21:17 357 查看
[align=left]Problem Description[/align]
ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.
 

[align=left]Output[/align]
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

[align=left]Sample Input[/align]

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

[align=left]Sample Output[/align]

1
2
2
1
1
2
None
2
3

 

题意:这道题还是对栈和队列的一个模拟,FILO表示先进后出,这是栈;FIFO先进先出这是队列,我们自要做到模拟他的过程就行。

代码:

#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<stack>
using namespace std;
void init(int n)
{
char c[10];
queue<int>q;
int a;
while(n--)
{
int k;
scanf("%s",c);
if(!strcmp(c,"IN"))
{
scanf("%d",&a);
q.push(a);
}
else if(!strcmp(c,"OUT"))
{
if(!q.size())
printf("None\n");
else
{
printf("%d\n",q.front());
q.pop();
}
}
}
}
void initt(int n)
{
char c[10];
int a;
stack<int>s;
while(n--)
{
scanf("%s",c);
if(!strcmp(c,"IN"))
{
scanf("%d",&a);
s.push(a);
}
else if(!strcmp(c,"OUT"))
{
if(!s.size())
{
printf("None\n");
}
else
{
printf("%d\n",s.top());
s.pop();
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
char c[10];
while(t--)
{
int n;
scanf("%d",&n);
scanf("%s",c);
if(strcmp(c,"FIFO")==0)
init(n);
else if(!strcmp(c,"FILO"))
initt(n);
else
printf("error\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: