您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表四:有序链表的归并

2016-09-18 21:04 211 查看

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Example Input

6 5
1 23 26 45 66 99
14 21 28 50 100


Example Output

1 14 21 23 26 28 45 50 66 99 100
#include <bits/stdc++.h>
using namespace std;
struct node
{
int data;
node *next;
};
node *create(int n)
{
node *head,*tail,*p;
int i;
head=new(node);
head->next=NULL;
tail=head;
for(i=0; i<n; i++)
{
p=new(node);
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return (head);
}

node mer(node *h1,node *h2)
{
node *p1,*p2,*tail;
p1=h1->next;
tail=h1;
p2=h2->next;
while(p1&&p2)
{
if(p1->data<p2->data)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
}
while(p1)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
while(p2)
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
return (*h1);
}

void display(node *head)
{
node *p;
p=head->next;
while(p)
{
if(p->next==NULL)
printf("%d\n",p->data);
else
printf("%d ",p->data);
p=p->next;
}
}
int main()
{
int n,m;
node *h1,*h2,*h;
scanf("%d %d",&m,&n);
h1=create(m);
h2=create(n);
mer(h1,h2);
display(h1);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 链表