您的位置:首页 > 其它

poj-【2891 Strange Way to Express Integers】

2016-09-18 19:15 225 查看
Strange Way to Express Integers

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 14314 Accepted: 4642
Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find
the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai,ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input
2
8 7
11 9

Sample Output
31
题目很难搞懂 拿样例说一下吧

2 代表有2组数据 

8 7  x=7(mod 8) 

11 9 x=9(mod 11) 

求最小的 x 的值 

<span style="font-size:18px;">#include<cstdio>
#define LL long long
void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
if(b==0)
{
y=0;x=1;
d=a;
}
else
{
exgcd(b,a%b,d,y,x);
y-=x*(a/b);
}
}
int main()
{
int T;
while(scanf("%d",&T)!=EOF)
{
LL a1,r1,i,flag=0,a2,r2,k1,k2,d,c,t,x1;
scanf("%lld%lld",&a1,&r1);
if(T==1)
{
if(a1<=r1)
printf("-1\n");
else
printf("%lld\n",r1);
continue;
}
for(i=1;i<T;++i)
{
scanf("%lld%lld",&a2,&r2);//r2是余数
if(flag)
continue;
c=r2-r1;
exgcd(a1,a2,d,k1,k2);
if(c%d)
{
flag=1;
//break;
}
x1=k1*c/d;
t=a2/d;
x1=(x1%t+t)%t;
r1+=x1*a1;
a1=a1/d*a2;
}
if(flag)
printf("-1\n");
else
printf("%lld\n",r1);
}
return 0;
} </span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: