您的位置:首页 > 其它

HDU-5879 Cure(精度)(极限)

2016-09-18 14:26 477 查看

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7400    Accepted Submission(s): 1099


[align=left]Problem Description[/align]
Given an integer n,
we only want to know the sum of 1/k2 where k from 1 to n.
 

[align=left]Input[/align]
There are multiple cases.

For each test case, there is a single line, containing a single positive integer n. 

The input file is at most 1M.

 

[align=left]Output[/align]
The required sum, rounded to the fifth digits after the decimal point.
 

[align=left]Sample Input[/align]

1
2
4
8
15

 

[align=left]Sample Output[/align]

1.00000
1.25000
1.42361
1.52742
1.58044

首先要知道∑1/(i*i)有极限,所以计算到一定数值以后结果会不再变化(小数点后后5位),然后找到边界1e6。

注意1M的输入。and atoi()

//下面盗用队友代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
char str[10000005];
int main()
{
while(~scanf("%s",str))
{
int len = strlen(str);
double tosum = 0;
if(len <= 6)
{
if(len < 6 || str[0] == '1')
{
int n = atoi(str);
for(int i = 1;i <= n;i++)
{
double tmp = i;
tosum += 1/(tmp*tmp);
}
printf("%.5f\n",tosum);
}
else
printf("1.64493\n");
}
else if(len > 6)
printf("1.64493\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: