您的位置:首页 > 其它

例题:安迪的第一个字典(UVa 10815)

2016-09-18 10:20 316 查看
【问题描述】输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写。

【样例输入】

Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the

road. The sign read: "Disneyland Left."
So they went home.
【样例输出】
a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when
【代码】

#include<iostream>
#include<set>
#include<string>
#include<sstream>
using namespace std;

set<string> dict;

int main()
{
string s, buf;
while (cin >> s)
{
for (int i = 0; i < s.length(); i++)
{
if (isalpha(s[i]))s[i] = tolower(s[i]);
else
s[i] = ' ';
}
stringstream ss(s);
while (ss >> buf)dict.insert(buf);
for (set<string>::iterator it = dict.begin(); it != dict.end(); it++)
cout << *it << endl;
}
return 0;
}

【分析】
set是数学上的集合,它是一个不包含重复元素的集合,并且自动重小到大排序。输入时把所有非字母的字符变成空格,然后利用stringstream得到各个单词。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: