您的位置:首页 > 其它

bzoj 2456: mode(找众数)

2016-09-17 14:24 351 查看

2456: mode

Time Limit: 1 Sec  Memory Limit: 1 MB
Submit: 3607  Solved: 1515

[Submit][Status][Discuss]

Description

给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。

Input

第1行一个正整数n。

第2行n个正整数用空格隔开。

Output

    一行一个正整数表示那个众数。

Sample Input

5

3 2 3 1 3

Sample Output

3

HINT

100%的数据,n<=500000,数列中每个数<=maxlongint。
思路:对两两不相等的数进行抵消,则最后剩下的数则是该众数! 用num记录当前抵消后剩下的数,当num=0的时候把该数变为tmp,不等则cnt--,相等则cnt++ 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int tot = 1 , n , num , tem;
scanf("%d%d",&n,&num);
for(int i = 2 ; i <= n ; i++)
{
scanf("%d",&tem);
if(tot == 0)
{
tot = 1;
num = tem;
continue;
}
if(num == tem)
tot++;
else
tot--;
}
printf("%d\n",num);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: