您的位置:首页 > 其它

UVa 437 The Tower of Babylon(经典动态规划)

2016-09-17 01:47 369 查看
传送门

Description

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story: The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi , yi , zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked. Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi , yi and zi . Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format ‘Case case: maximum height = height’

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

思路

  题意:

  有n(n≤30)中立方体,每种都有无穷多个。要求选一些立方体摞成一根尽量高的柱子(可以自行选择哪一条边作为高),使得每个立方体的底面长宽分别严格小于它下方立方体的底面长宽。

  思路:

  矩形嵌套的变形题,将题目信息转化为矩形嵌套来做。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 35;
struct Node{
int len,wid,hei;
}node[maxn*3];

bool cmp(struct Node x,struct Node y)
{
if (x.len == y.len)	return x.wid < y.wid;
else	return x.len < y.len;
}

int main()
{
int N,Case = 0;
while (~scanf("%d",&N) && N)
{
int x,y,z,p = 0,res = 0;
int dp[maxn*3];
for (int i = 0;i < N;i++)
{
scanf("%d%d%d",&x,&y,&z);
node[p].len = x>y?x:y;node[p].wid = x<y?x:y;node[p++].hei = z;
node[p].len = x>z?x:z;node[p].wid = x<z?x:z;node[p++].hei = y;
node[p].len = y>z?y:z;node[p].wid = y<z?y:z;node[p++].hei = x;
}
sort(node,node+p,cmp);
for (int i = 0;i < p;i++)
{
dp[i] = node[i].hei;
for (int j = 0;j < i;j++)
{
if (node[i].len > node[j].len && node[i].wid > node[j].wid && dp[i] < dp[j] + node[i].hei)
{
dp[i] = dp[j] + node[i].hei;
}
}
res = max(res,dp[i]);
}
printf("Case %d: maximum height = %d\n",++Case,res);
}
return 0;
}


  

// UVa437 The Tower of Babylon
// Rujia Liu
// 算法:DAG上的最长路,状态为(idx, k),即当前顶面为立方体idx,其中第k条边(排序后)为高
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define REP(i,n) for(int i = 0; i < (n); i++)

const int maxn = 30 + 5;
int n, blocks[maxn][3], d[maxn][3];

void get_dimensions(int* v, int b, int dim)
{
int idx = 0;
REP(i,3) if(i != dim) v[idx++] = blocks[b][i];
}

int dp(int i, int j)
{
int& ans = d[i][j];
if(ans > 0) return ans;
ans = 0;
int v[2], v2[2];
get_dimensions(v, i, j);
REP(a,n) REP(b,3)
{
get_dimensions(v2, a, b);
if(v2[0] < v[0] && v2[1] < v[1]) ans = max(ans, dp(a,b));
}
ans += blocks[i][j];
return ans;
}

int main()
{
int kase = 0;
while(scanf("%d", &n) == 1 && n)
{
REP(i,n)
{
REP(j,3) scanf("%d", &blocks[i][j]);
sort(blocks[i], blocks[i]+3);
}
memset(d, 0, sizeof(d));
int ans = 0;
REP(i,n) REP(j,3) ans = max(ans, dp(i,j));
printf("Case %d: maximum height = %d\n", ++kase, ans);
}
return 0;
}

  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: