您的位置:首页 > 产品设计 > UI/UE

01-复杂度2 Maximum Subsequence Sum (25分)

2016-09-16 21:52 183 查看
Given a sequence of KKK integers { N1N_1N​1​​, N2N_2N​2​​, …, NKN_KN​K​​ }. A continuous subsequence is defined to be { NiN_iN​i​​, Ni+1N_{i+1}N​i+1​​, …, NjN_jN​j​​ } where 1≤i≤j≤K1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KKK (≤10000\le 10000≤10000). The second line contains KKK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

#include<stdio.h>
int main(){
int result=0,thissum=0,N,digit[10005],first=0,begin=0,last=0;
scanf("%d",&N);
scanf("%d",digit);
/*我们要先判断一个数的情况,如果不判断的话,result初始值为0,在赋值的过程中result不可能小于0,但确实存在负数的情况*/
result=thissum=digit[0];
for(int i=1;i<N;i++){
scanf("%d",digit+i);
if(thissum>=0)
thissum+=digit[i];
else{
thissum=digit[i];
begin=i;            //begin表示当前最大和的开始位置
}
if(thissum>result){    //如果当前最大和比结果大则更新结果以及起始位置
last=i;
first=begin;
result=thissum;
}
}
if(result<0){               //如果最终结果为负数,则输出首尾元素
result=0;
first=0;
last=N-1;
}
printf("%d %d %d",result,digit[first],digit[last]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: