您的位置:首页 > 其它

hdu 5773 The All-purpose Zero (LIS)

2016-09-16 17:52 302 查看
题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=5773


The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1834    Accepted Submission(s): 867

Problem Description

?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing
(strictly) subsequence he can get.

 

Input

The first line contains an interger T,denoting the number of the test cases.(T <= 10)

For each case,the first line contains an interger n,which is the length of the array s.

The next line contains n intergers separated by a single space, denote each number in S.

 

Output

For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.

 

Sample Input

2
7
2 0 2 1 2 0 5
6
1 2 3 3 0 0

 

Sample Output

Case #1: 5
Case #2: 5

HintIn the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.

 

Author

FZU

 

Source

2016 Multi-University Training Contest 4

题目大意:求最长不下降子序列,0可以变成任何数

解析:为了尽可能多的0在序列中,输入数时,记录0的个数,如果不是0, 将这个数减去它前面0的个数,求最长子序列之后加上0的个数即可

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 1000009
using namespace std;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int a
, dp
;

int main()
{
int i, t, n, cnt = 0;
cin >> t;
while(t--)
{
scanf("%d", &n);
int k = 0, r = 0, num;
for(i = 1; i <= n; i++)
{
scanf("%d", &num);
if(num == 0) k++;
else a[++r] = num - k;
}
memset(dp, 0x3f, sizeof(dp));
for(i = 1; i <= r; i++)
{
*lower_bound(dp, dp + r, a[i]) = a[i];
}
int l = lower_bound(dp, dp + r, inf) - dp;
l += k;
printf("Case #%d: %d\n", ++cnt, l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: