您的位置:首页 > 编程语言 > C语言/C++

1047. Student List for Course (25)

2016-09-15 20:16 471 查看

1047. Student List for Course (25)

 

时间限制

400 ms

内存限制

64000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters
plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students'
names in alphabetical order. Each name occupies a line.
Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1


 

特地尝试用了链表和插入排序的方法,速度太慢,最后一个会超时。下次用快排再试下。

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAX 2600

typedef struct node
{
char name[5];
struct node* next;
}NODE;

typedef struct course
{
int count;
NODE *head;
}COURSE;

void Insert(COURSE *a,char *InputName)
{
NODE *p,*temp;
int i;
a->count++;
p = a->head->next;
temp = (NODE*)malloc(sizeof(NODE));
for(i=0;i<5;i++)
{
temp->name[i] = InputName[i];
}
temp->next = NULL;
if(p == NULL)
{
a->head->next = temp;
return;
}
if(strcmp(p->name ,temp->name)>0)
{
a->head->next = temp;
temp->next = p;
return;
}
if(p->next == NULL)
{
if(strcmp(p->name ,temp->name)<0)
{
p->next = temp;
return;
}
else
{
a->head->next = temp;
temp->next = p;
return;
}
}
while(p->next != NULL)
{
/*if(((p->next->name[0]-'A')<<24)+((p->next->name[1]-'A')<<16)+((p->next->name[2]-'A')<<8)+(p->next->name[3]-'A')-
(((temp->name[0]-'A')<<24)+((temp->name[1]-'A')<<16)+((temp->name[2]-'A')<<8)+(temp->name[3]-'A'))<0)
*/		if(strcmp(p->next->name ,temp->name)<0)
{
4000

p = p->next;
}
else
{
break;
}
}
temp->next = p->next;
p->next = temp;
return;
}

int main()
{
int N,K,C;
int i,j;
int CourseCount,index;
NODE *p;
char InputName[5];
COURSE a[MAX];
scanf("%d%d",&N,&K);
for(i=1;i<=K;i++)  //初始化课程
{
a[i].count = 0;
a[i].head = (NODE*)malloc(sizeof(NODE));
a[i].head->next = NULL;
}
for(i=0;i<N;i++)
{
scanf("%s%d",InputName,&CourseCount);
for(j=0;j<CourseCount;j++)
{
scanf("%d",&index);
Insert(&a[index],InputName);
}
}
for(i=1;i<=K;i++)
{
printf("%d %d\n",i,a[i].count);
p = a[i].head->next;
while(p!=NULL)
{
printf("%s\n",p->name);
p = p->next;
}
}
//system("pause");
return 0;
}


 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息