您的位置:首页 > 其它

HDU2594-Simpsons’ Hidden Talents

2016-09-14 11:35 295 查看


Simpsons’ Hidden Talents

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
32768/32768 K (Java/Others)

                                                                                                     Total Submission(s): 7377    Accepted Submission(s): 2628


Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.

 

Sample Input

clinton
homer
riemann
marjorie

 

Sample Output

0
rie 3

 

Source

HDU 2010-05 Programming Contest

 

Recommend

lcy

     
题意:问给出两个字符串s1和s2,问s1的前缀和s2的后缀最大匹配的数量

         解题思路:可以把s1,s2连接起来,strcat(s1,s2)函数就是把s2连接到s1的末端连接完之后就是对串s1进行求next数组,接下来就是判断next[k]与len1和len2的关系

#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
#include <stack>

using namespace std;

char s1[500009],s2[500009];
int nt[500009];
int n;

void get_next()
{
nt[0]=-1;
for(int i=0; i<n; i++)
{
int k=nt[i];
while(k>=0&&s1[i]!=s1[k])
k=nt[k];
nt[i+1]=k+1;
}
}

int main()
{
while(~scanf("%s %s",s1,s2))
{
int len1=strlen(s1),len2=strlen(s2);
strcat(s1,s2);//把s2连接到s1的末端
n=strlen(s1);
get_next();
int k=n;
while(nt[k]>len1||nt[k]>len2)
k=nt[k];
if(nt[k]==0)
{
printf("0\n");continue;
}
for(int i=0;i<nt[k];i++)
printf("%c",s1[i]);
printf(" %d\n",nt[k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: