您的位置:首页 > 大数据 > 人工智能

hdoj 1532 Drainage Ditches 【最大流---裸题】

2016-09-13 18:11 288 查看


Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15420    Accepted Submission(s): 7350


Problem Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection
1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to
Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

 

Sample Output

50

 

Source

USACO 93

题意:

n个点,m个边,

每个边有一个流量---

求1到n的最大流量----

最大流问题-Ford-Fulkerson算法------

代码:

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
LL map[300][300];
struct node {
int to,cc,rt;
}A,B;
vector <node> T[300];
void add(int ii,int jj)
{
A.to=jj;A.cc=map[ii][jj];A.rt=T[jj].size();
B.to=ii;B.cc=map[jj][ii];B.rt=T[ii].size();
T[ii].push_back(A);
T[jj].push_back(B);
}
int n;
bool fafe,guo[300];
int dfs(int xx,int lp)
{
if (fafe)
return false;
if (xx==n)
{
fafe=true;
return lp;
}
guo[xx]=false;
for (int i=0;i<T[xx].size();i++)
{
if (guo[T[xx][i].to]&&T[xx][i].cc>0)
{
LL k=dfs(T[xx][i].to,min(lp,T[xx][i].cc));
if (k)
{
T[xx][i].cc-=k;
T[T[xx][i].to][T[xx][i].rt].cc+=k;
return k;
}
}
}
return false;
}
int main()
{
int m;
while (~scanf("%d%d",&m,&n))
{
int a,b,c;
memset(T,0,sizeof(T));
memset(map,0,sizeof(map));
for (int i=0;i<m;i++)
{
scanf("%d%d%d",&a,&b,&c);
map[a][b]+=c;
}
for (int i=1;i<n;i++)
{
for (int j=i+1;j<=n;j++)
{
if (map[i][j]||map[j][i])
add(i,j);
}
}
int lp=1;
LL s=0;
while (lp)
{
fafe=false;memset(guo,true,sizeof(guo));
lp=dfs(1,122222222);
if (lp)
s+=lp;
}
printf("%lld\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: