您的位置:首页 > 其它

hdu 3555 Bomb(数位DP)

2016-09-13 14:16 323 查看
[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.
 

[align=left]Sample Input[/align]

3
1
50
500

 

[align=left]Sample Output[/align]

0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

 

题意:与HDU2089一样的意思,要求1~n的范围内含有49的数字的个数;

思路:dfs+记忆化,注意输入输出为64位整型;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
__int64 dp[500][2],a[500];
__int64 dfs(int len,int p,int d)
{
if(!len)
return 1;
if(dp[len][p]&&!d)
return dp[len][p];
int f=a[len];
__int64 ans=0;
int s=d?f:9;
for(int i=0;i<=s;i++)
{
if(p&&i==9)
continue;
ans=ans+dfs(len-1,i==4,d&&i==s);
}
if(!d)
dp[len][p]=ans;
return ans;
}
__int64 solve(__int64 n)
{
int len=0;
while(n)
{
a[++len]=n%10;
n=n/10;
}
return dfs(len,0,1);
}
int main()
{
int t;
scanf("%d",&t);
memset(dp,0,sizeof(dp));
__int64 n,ans;
while(t--)
{
scanf("%I64d",&n);
ans=solve(n);
printf("%I64d\n",n-ans+1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: