您的位置:首页 > 其它

PAT----1002. A+B for Polynomials (25)

2016-09-13 14:05 453 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


import java.util.*;

public class test {
public static void main(String[]args){
Scanner sc=new Scanner(System.in);
int n1=sc.nextInt();
Map<Integer,Double> map=new TreeMap<Integer,Double>(
new Comparator<Integer>(){
@Override
public int compare(Integer o1, Integer o2) {

return o2-o1;
}
});

for(int i=0;i<n1;i++){
int a=sc.nextInt();
double b=sc.nextDouble();
b=Math.round(b*10)/10.0;
if(!map.containsKey(a)){

map.put(a, b);}else{
map.put(a, map.get(a)+b);
if(map.get(a)<=0.0001){map.remove(a);}//题目要求double不能为0;
}
}
int n2=sc.nextInt();
for(int i=0;i<n2;i++){
int a=sc.nextInt();
double b=sc.nextDouble();b=Math.round(b*10)/10.0;
if(!map.containsKey(a)){map.put(a, b);}else{
map.put(a, map.get(a)+b);
if(map.get(a)<=0.0001){map.remove(a);}//题目要求double不能为0;
}
}
System.out.print(map.size());
for(Map.Entry<Integer, Double>m:map.entrySet()){
System.out.print(" "+m.getKey()+" "+m.getValue());
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: