您的位置:首页 > 其它

POJ 1961 Period【KMP最小循环节】

2016-09-12 22:51 363 查看
Period

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 16685 Accepted: 8024
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 

number zero on it.
Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


题意:求一个串的以0开头的长度1<1i<=len前缀的最小循环节;

思路:借助KMP的next:用公式 i%(i-ne[i])==-0&&ne[i]  要理解每一个变量的意义和公式怎样推导出来的,i表示判断的是0-(i-1)是否含有·最小循环节 串的长度是i;

失误:失误在输出格式上了,习惯加了Case %d:    以后要直接复制就行,格式要看好;

AC代码:

#include<cstdio>
#include<cstring>

const int MAXN=1e6+22;
int ne[MAXN];
char str[MAXN];

void Get_ne(char *T,int *ne,int L)
{
ne[0]=-1;
int i=0,j=-1;
while(i<L)
{
if(j<0||T[i]==T[j]) ne[++i]=++j;
else j=ne[j];
}
}
int main()
{
int N,i,Kase=0;
while(scanf("%d",&N),N)
{
scanf("%s",str);
int len=strlen(str);
Get_ne(str,ne,len);
int ans=0;

printf("Test case #%d\n",++Kase);
for(i=1;i<=len;++i)
{
if(i%(i-ne[i])==0&&ne[i])
{
printf("%d %d\n",i,i/(i-ne[i]));
}
}
puts("");
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: