您的位置:首页 > 其它

poj2406--kmp next的应用

2016-09-12 11:26 316 查看
Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 44606 Accepted: 18632
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:kmp算法中next数组的含义是next【i】表示前i个字符串中最长的前缀串和后缀串相等,故n-next【n】就表示前n个字符串的最小周期。
ac代码:
#include<iostream>

#include<string.h>

#include <cstdio>

using namespace std;

int next[1000005];

char s[1000005];

void getnext()

{

    int i=0,j=-1;

    next[0]=-1;

    int len=strlen(s);

    while(i<len)

    {

        if(s[i]==s[j]||j==-1)

        {

            i++;

            j++;

            next[i]=j;

        }

        else

            j=next[j];

    }

}

int main()

{

    while(scanf("%s",s)>0)

    {

        if(s[0]=='.')

            break;

        int len=strlen(s);

        getnext();

        if(len%(len-next[len])==0)

            printf("%d\n",len/(len-next[len]));

        else

            printf("1\n");

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: