您的位置:首页 > 其它

Hdu 1880 魔咒词典(hash链表)

2016-09-10 16:54 369 查看
题目1029:魔咒词典

时间限制:1000ms 内存限制:32 m

题目描述:

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”输入:

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

样例输入:

[expelliarmus] the disarming charm

[rictusempra] send a jet of silver light to hit the enemy

[tarantallegra] control the movement of one’s legs

[serpensortia] shoot a snake out of the end of one’s wand

[lumos] light the wand

[obliviate] the memory charm

[expecto patronum] send a Patronus to the dementors

[accio] the summoning charm

@END@

4

[lumos]

the summoning charm

[arha]

take me to the sky

样例输出:

light the wand

accio

what?

what?

来源:

2008年浙江大学计算机及软件工程研究生机试真题

/*
链表hash.
边权互建.
*/
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define LL long long
#define MAXN 100001
#define MAXL 110
#define ha1 31
#define ha2 119
#define mod  300009
using namespace std;
char ss[MAXL],s[mod][81];
struct edge{int v,next;}e[mod];
int x,l,head[mod+10],cut,xx,yy;
LL tot,tot2;
int read()
{
int x=0,f=1;char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch>='0'&&ch<='9')x=x*10+ch-48,ch=getchar();
return x*f;
}
int hhash(char s[],int p){
tot=0,tot2=0;
int i;
for(i=p;s[i-1]!=']'&&i<l;i++)
{
tot=tot*ha1+s[i]-'A';tot%=mod;
tot2=tot2*ha2+s[i]-'A';tot2%=mod;
}
if(i<l-1) x=i;
tot%mod,tot2%=mod;
}
void add(int u,int v,int l,int r)
{
e[++cut].v=v;
e[cut].next=head[u];
head[u]=cut;
for(int i=l;i<=r;i++)
s[cut][i-l+1]=ss[i];
}
int query(int u,int v)
{
for(int i=head[u];i;i=e[i].next)
{
if(e[i].v==v) return i;
}
return 0;
}
int main(){
while(gets(ss))
{
l=strlen(ss);x=-1;
hhash(ss,0);
add(tot,tot2,x+1,l);
if(tot==-191754&&tot2==-103031) break;
hhash(ss,x+1);
add(tot,tot2,1,x-2);
}
int n;
n=read();
while(n--)
{
gets(ss);
l=strlen(ss);
hhash(ss,0);
int ans=query(tot,tot2);
if(!ans)
{
printf("what?\n");continue;
}
for(int i=1;s[ans][i]!='\0';i++)
printf("%c",s[ans][i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: