您的位置:首页 > 其它

南阳oj 233 sort it

2016-09-10 16:38 246 查看
描述

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.

For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

输入

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

输出

For each case, output the minimum times need to sort it in ascending order on a single line.

样例输入

3
1 2 3
4
4 3 2 1


样例输出

0
6


以下附上代码

#include<stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
int a[1002];
int main()
{
int t,n,i,j;
while(~scanf("%d",&n)&&n)
{
int t,i,j,m=0;
for(i=0; i<n; i++)
cin>>a[i];
for(i=0; i<n; i++)
for(j=i+1; j<n; j++)
if(a[i]>a[j])
{
t=a[i];
a[i]=a[j];
a[j]=t;
m++;
}
cout<<m<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: