您的位置:首页 > 产品设计 > UI/UE

HDU-1297 Children’s Queue(递推)(高精度)

2016-09-10 10:06 363 查看

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13954    Accepted Submission(s): 4596


[align=left]Problem Description[/align]
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more
than one girl stands side by side. The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

[align=left]Input[/align]
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

[align=left]Output[/align]
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

[align=left]Sample Input[/align]

1
2
3

 

[align=left]Sample Output[/align]

1
2
4

 

[align=left]Author[/align]
SmallBeer (CML)
 

[align=left]Source[/align]
杭电ACM集训队训练赛(VIII)

  题意:

F:girl          M:boy

给你一个n,代表队列的容量及girl的数量,女孩不可以单独出现,求方法的总数。

思路:

设a[i]代表此时的总数。

因为女孩不可以单独出现,所以队列最后的情况可能是一个boy(M),两个girl(F)。

M:前i-1个人肯定是满足要求的,所以次数为 a[i-1]

FF:

1.前i-2个满足要求,所以次数为a[i-2]

2.前i-2个不满足要求,所以就是MF+FF了,所以次数为a[i-4]

所以递推式就出来了,a[i] = a[i-1] + a[i-2] + a[i-4]

因为n最大1000,所以太大了,高精度。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long a[1005][105]={0};
void Init()
{
int i,j;
a[1][0] = 1;
a[2][0] = 2;
a[3][0] = 4;
a[4][0] = 7;
for(i = 5;i <= 1000;i++)
{
for(j = 0;j <= 100;j++)
{
a[i][j] += a[i-1][j] + a[i-2][j] + a[i-4][j];
a[i][j+1] += a[i][j] / 10000;
a[i][j] %= 10000;
}
}
}
int main()
{
int n;
Init();
while(~scanf("%d",&n))
{
int j;
for(j = 100;j >= 0;j--)
{
if(a
[j] != 0)
{
printf("%d",a
[j]);
break;
}
}
for(j = j-1;j >= 0;j--)
printf("%04d",a
[j]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: