您的位置:首页 > 其它

PAT 1063. Set Similarity (25)(set的使用)

2016-09-09 21:22 423 查看

官网

1063. Set Similarity (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3

3 99 87 101

4 87 101 5 87

7 99 101 18 5 135 18 99

2

1 2

1 3

Sample Output:

50.0%

33.3%

题目大意

1.相似度定义为俩个数列中相同的数字的个数(重复的只计算一次)/所有不重复的数字的个数。

解题思路

1.用set保存每一组数,然后a.find(一个数) != a.end()可以判断a中是否有这个数,这样该统计不同的数的个数就好求了。

AC代码

#include <iostream>
#include<vector>
#include<set>
#include<iomanip>
using namespace std;
//感觉set就是里面装的东西不是重复的
//vector<set> a;

set<int> a[52];
int main()
{
//存入set
int n;
cin >> n;
int m,value;
for (int i = 1; i <= n; i++)
{
cin >> m;
while (m)
{
cin >> value;
a[i].insert(value);
m--;
}
}
//查询
int k,u,v;
cin >> k;
while (k--)
{
cin >> u>>v;
set<int>::iterator it;
int cnn = 0;
for (it = a[u].begin(); it != a[u].end(); it++)
{
//这里开始也出错了
if (a[v].find(*it) != a[v].end())
{
cnn++;
}
}
//cout <<"v"<< a[v].size() << endl;
//cout << "cnt:" << cnn << " v:" << a[v].size << " u:" << a[u].size() << endl;
//没有乘以一百卧槽
cout << fixed << setprecision(1) << (float)cnn*100 / (a[v].size() + a[u].size() - cnn) << "%" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: