您的位置:首页 > 产品设计 > UI/UE

POJ 1458 - Common Subsequence(LCS)

2016-09-09 20:35 330 查看
Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 48245 Accepted: 19888

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

解题思路:

最长公共子序列裸题,给出两个字符串,找出最长公共子序列的长度(不必是连续的).

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 205;
char str1[maxn];
char str2[maxn];
int dp[maxn][maxn];
int main()
{
while(~scanf("%s%s",str1,str2))
{
int len1 = strlen(str1);
int len2 = strlen(str2);
for(int i = 0;i <= len1;i++)    dp[i][0] = 0;
for(int i = 0;i <= len2;i++)    dp[0][i] = 0;
for(int i = 0;i < len1;i++)
{
for(int j = 0;j < len2;j++)
{
if(str1[i] == str2[j])  dp[i+1][j+1] = dp[i][j] + 1;
else    dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]);
}
}
printf("%d\n",dp[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: