您的位置:首页 > 其它

CCF 201509-2 日期计算 (水题)

2016-09-09 11:21 501 查看
问题描述
  给定一个年份y和一个整数d,问这一年的第d天是几月几日?

  注意闰年的2月有29天。满足下面条件之一的是闰年:

  1) 年份是4的整数倍,而且不是100的整数倍;

  2) 年份是400的整数倍。
输入格式
  输入的第一行包含一个整数y,表示年份,年份在1900到2015之间(包含1900和2015)。

  输入的第二行包含一个整数d,d在1至365之间。
输出格式
  输出两行,每行一个整数,分别表示答案的月份和日期。
样例输入
2015

80
样例输出
3

21
样例输入
2000

40
样例输出
2

9

析:就从一月份开始暴力,判断一下闰年即可。

代码如下:

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#define freopenr freopen("in.txt", "r", stdin)
#define freopenw freopen("out.txt", "w", stdout)
using namespace std;

typedef long long LL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const double inf = 0x3f3f3f3f3f3f;
const LL LNF = 0x3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 1e4 + 5;
const int mod = 1e9 + 7;
const int dr[] = {-1, 0, 1, 0};
const int dc[] = {0, 1, 0, -1};
const char *Hex[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline int Min(int a, int b){ return a < b ? a : b; }
inline int Max(int a, int b){ return a > b ? a : b; }
inline LL Min(LL a, LL b){ return a < b ? a : b; }
inline LL Max(LL a, LL b){ return a > b ? a : b; }
inline bool is_in(int r, int c){
return r >= 0 && r < n && c >= 0 && c < m;
}

bool is_leapyear(int x){
if(x % 400 == 0)  return true;
if(x % 100 == 0)  return false;
if(x % 4 == 0)  return true;
return false;
}

int main(){
while(scanf("%d %d", &n, &m) == 2){
int month, day;
if(is_leapyear(n)){
month = 0;
while(m - monn[month] > 0)  m -= monn[month], ++month;
day = m;
}
else{
month = 0;
while(m - mon[month] > 0)  m -= mon[month], ++month;
day = m;
}
printf("%d\n%d\n", month, day);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: