您的位置:首页 > 其它

poj 2352 Stars

2016-09-08 21:39 183 查看
Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 42707   Accepted: 18587

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999
/*
题意给你n个星星的坐标,每一个星星的等级为:在不在这个星星右边并且不比这个星星高的星星的个数
然后出处每个等级星星的个数
树状数组,一开始把上一个题的模板扒过来的......真是伤啊,这个题更新点的时候要把右边的点更新到MAXN要不然会漏掉条件的
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#define N 32010
using namespace std;
int n;
int c
;
int cur
;//统计每个等级的星星
int lowbit(int x)
{
return x&(-x);
}
int getx(int x)
{
int ans=0;
while(x>0)
{
ans+=c[x];
x-=lowbit(x);
}
return ans;
}
void update(int x)
{
while(x<=N)
{
c[x]++;
x+=lowbit(x);
}
}
int main()
{
//freopen("in.txt","r",stdin);
int x,y;
while(scanf("%d",&n)!=EOF&&n)
{
memset(cur,0,sizeof cur);
memset(c,0,sizeof c);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
update(x+1);
//for(int j=1; j<=n; j++)
//    cout<<c[j]<<" ";
//cout<<endl;
//cout<<getx(x+1)-1<<endl;
cur[getx(x+1)-1]++;
}
//cout<<endl;
for(int i=0;i<n;i++)
printf("%d\n",cur[i]);
}
return 0;
}
/*
_ooOoo_
o8888888o
88" . "88
(| -_- |)
O\  =  /O
____/`---'\____
.'  \\|     |//  `.
/  \\|||  :  |||//  \
/  _||||| -:- |||||-  \
|   | \\\  -  /// |   |
| \_|  ''\---/''  |   |
\  .-\__  `-`  ___/-. /
___`. .'  /--.--\  `. . __
."" '<  `.___\_<|>_/___.'  >'"".
| | :  `- \`.;`\ _ /`;.`/ - ` : | |
\  \ `-.   \_ __\ /__ _/   .-` /  /
======`-.____`-.___\_____/___.-`____.-'======
`=---='
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
I have a dream!A AC deram!!
orz orz orz orz orz orz orz orz orz orz orz
orz orz orz orz orz orz orz orz orz orz orz
orz orz orz orz orz orz orz orz orz orz orz

*/

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: