您的位置:首页 > 大数据 > 人工智能

UVA 514 Rails(栈)

2016-09-08 13:21 423 查看
Question:

Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N≤1000 coaches numbered in increasing order 1,2,…,N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1.a2,…,aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1,2,…,N The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last “null” block of the input file.

Sample Input

5

1 2 3 4 5

5 4 1 2 3

0

6

6 5 4 3 2 1

0

0

Sample Output

Yes

No

Yes

题目大意:在A车轨上有1~n的车厢,所有的车厢都可以进c的中转站调整(也可以直接开往B车轨上),然后按一定顺序开往B车轨上,先给你一个B车轨上的车厢顺序,问是否能按此种顺序开出

解题思路:开往C中转站的车厢符合后进先出,是一个栈

(https://www.bnuoj.com/v3/contest_show.php?cid=8307#problem/B)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>

using namespace std;
const int maxn=1005;
int a[maxn],n;
int main()
{
while(~scanf("%d",&n),n)
{
while(1)
{
scanf("%d",&a[1]);
if(a[1]==0)
break;
for(int i=2;i<=n;i++)
scanf("%d",a+i);
stack<int> s;
int A=1,B=1,flag=1;  //A表示原来的递增序列,B表示给出的序列
while(B<=n)
{
if(a==A)   // 刚好相等则直接开过去
{
A++;B++;
}
else if(!s.empty()&&s.top()==a[B])  //如果等于C中转站的头则从中转站开出
{
s.pop();B++;
}
else if(A<=n)   //不满足以上两种情况,则将A推进中转站
s.push(A++);
else
{
flag=0;   //A全部被推入了中转站却不能条件
break;
}
}
if(flag==1)
printf("Yes\n");
else printf("No\n");
}
printf("\n");
}
return 0;
}


[b]体会:不熟悉栈,先做一些入门题熟悉
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 ACM