您的位置:首页 > 其它

UVA - 232 Crossword Answers

2016-09-07 15:48 363 查看
A crossword puzzle consists of a rectangular grid of black andwhite squares and two lists of definitions (or descriptions).

One list of definitions is for “words” to be written left toright across white squares in the rows and the other list is forwords to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.
The definitions correspond to the rectangular grid by means
of sequential integers on “eligible” white squares.
White squares with black squares immediately to the left or above
them are “eligible.” White squares with no squares either immediately to the left or above are also “eligible.” No other squares
are numbered. All of the squares on the first row are numbered.
The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of
the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.
An “across” word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another
white square in the same row.
The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in
the row or in the rightmost square of the row.
A “down” word for a definition is written on a sequence of white squares in a column starting on a
numbered square that does not follow another white square in the same column.
The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square
in the column or in the bottom square of the column.
Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.



Input
Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and1
≤ c ≤ 10), where r (the first number) is the number of rows in the puzzle and c (the second number)is the number of columns.
The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the
solution. Each of those c characters is an alphabetic character which is part of a word or the character ‘*’, which indicates a black
square.
The end of input is indicated by a line consisting of the single number ‘0’.
Output
Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the list
of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number
of their corresponding definitions.
The heading for the list of across words is ‘Across’. The heading for the list of down words is ‘Down’.
In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’ headings
should still appear.
Separate output for successive input puzzles by a blank line.
Sample Input
2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0
Sample Output
puzzle #1:
Across
1.AT
3.O
Down
1.A
2.TO
puzzle #2:
Across
1.AIM
4.DEN
7.ME
8.ONE
9.UPON
11.TO
12.SO
13.ERIN
15.SA
17.OR
18.IES
19.DEA
Down
1.A
2.IMPOSE
3.MEO
4.DO
5.ENTIRE
6.NEON
9.US
10.NE
14.ROD
16.AS
18.I

20.A

黑格是不可通过的,所有位于第一行和第一列的白格,以及上侧或者左侧紧靠着黑格的白格,都属于起始格,首先对这些白格编号,然后分别输出所有横向单词和竖向单词。

[cpp] view
plain copy

#include <iostream>  

#include<cstring>  

#include<cstdio>  

#define maxn 11  

using namespace std;  

char s[maxn][maxn];  

int n[maxn][maxn],u[maxn][maxn];  

int main(){  

int num,kase=0;  

int r,c;  

int flag=0;  

while(1)  

{  

cin>>r;  

if(!r) break;  

cin>>c;  

memset(n,0,sizeof(n));  

memset(u,0,sizeof(u));  

memset(s,0,sizeof(s));  

num=0;  

int ci,cj;  

int i=r;  

for(int j=0;j<=c;j++)  

n[i][j]=-1;  

int j=c;  

for(int i=0;i<=r;i++)//标记边界点  

    n[i][j]=-1;  

for(int i=0;i<r;i++)  

    for(int j=0;j<c;j++)  

{  

    cin>>s[i][j];  

}  

for(int i=0;i<r;i++)//标记黑格  

    for(int j=0;j<c;j++)  

    {  

        if(s[i][j]=='*')  

            n[i][j]=-1;  

    }  

for(int i=0;i<r;i++)//对于符合条件的起始格编号  

    for(int j=0;j<c;j++)  

    {  

        if(n[i][j]!=-1)  

            if(i==0||j==0||n[i-1][j]==-1||n[i][j-1]==-1)  

            n[i][j]=++num;  

    }  

if(flag) cout<<endl;  

flag=1;  

    cout<<"puzzle #"<<++kase<<':'<<endl;  

    cout<<"Across"<<endl;  

for(int i=0;i<r;i++)  

    for(int j=0;j<c;j++)  

    {  

        if(n[i][j]>=0&&!u[i][j])  

        {    printf("%3d",n[i][j]);  

            cout<<'.'<<s[i][j];  

        u[i][j]=1;  

        ci=i,cj=j;//防止直接处理i和j影响循环的进行  

            while(n[ci][cj+1]>=0)//如果右边有数,那么向右延伸  

        {  

            cout<<s[ci][cj+1];  

            u[ci][cj+1]=1;  

            cj++;  

        }  

        cout<<endl;  

        }  

    }  

    memset(u,0,sizeof(u));  

 cout<<"Down"<<endl;  

    for(int i=0;i<r;i++)  

    for(int j=0;j<c;j++)  

    {  

        if(n[i][j]>=0&&!u[i][j])  

        {   printf("%3d",n[i][j]);  

            cout<<'.'<<s[i][j];  

        u[i][j]=1;  

        ci=i,cj=j;  

            while(n[ci+1][cj]>=0)  

        {  

            cout<<s[ci+1][cj];  

            u[ci+1][cj]=1;  

            ci++;  

        }  

        cout<<endl;  

        }  

    }  

}  

return 0;  

}  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: