您的位置:首页 > 其它

poj3352 Road Construction(加最少边使图双联通)

2016-09-07 14:36 211 查看
Road Construction

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 11087Accepted: 5513
Description
It’s almost summer time, and that means that it’s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.
The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.
Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.
So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.
InputThe first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.
OutputOne line, consisting of an integer, which gives the minimum number of roads that we need to add.
Sample InputSample Input 1

10 12

1 2

1 3

1 4

2 5

2 6

5 6

3 7

3 8

7 8

4 9

4 10

9 10

Sample Input 2

3 3

1 2

2 3

1 3
Sample OutputOutput for Sample Input 1

2

Output for Sample Input 2

0



题解:

这道题的意思标题已经说了。

其实这道题目的意思就是求桥的个数。

我们可以先把环拿出来,因为环肯定是双联通的。把环缩点,然后重新建图树(肯定是树),我们需要把这颗树加边变成双联通的图,那么我们只需要加(num+1)/2(num是叶子节点的个数)条边就可以了。

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#include<cstring>
#include<vector>

const int maxn=1005;
vector<int> G[maxn];
int n,m;

int Clock,Dfn[maxn],Deg[maxn];//,Low[maxn];

bool Vi[maxn];
//树上可以不要这个,但是图中可能有环,now!=fa的方法会死循环

void Dfs(int now,int f){
Dfn[now]=++Clock;
Vi[now]=true;
int len=(int)G[now].size();
for(int i=0;i<len;++i){
int to=G[now][i];
if(to==f)continue;
if(!Vi[to])Dfs(to,now);
Dfn[now]=min(Dfn[now],Dfn[to]);
}
}

int Solve(){
memset(Deg,0,sizeof(Deg));
memset(Dfn,0,sizeof(Dfn));
memset(Vi,false,sizeof(Vi));
Clock=0;
Dfs(1,-1);
for(int i=1;i<=n;++i){
int len=(int)G[i].size();
for(int j=0;j<len;++j){
if(Dfn[G[i][j]]^Dfn[i]){
++Deg[Dfn[i]];
}
}
}
int ans=0;
for(int i=1;i<=n;++i){
ans+=(Deg[i]==1);
}
return (ans+1)>>1;
}

int main(){
int u,v;
while(~scanf("%d%d",&n,&m)){
for(int i=0;i<=n;++i){
G[i].clear();
}
for(int i=0;i<m;++i){
scanf("%d%d",&u,&v);
G[u].push_back(v),G[v].push_back(u);
}
printf("%d\n",Solve());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐