您的位置:首页 > 运维架构

UVaOJ 10048 Audiophobia(最小化最短路的最大权值边)

2016-09-06 15:41 405 查看
Audiophobia
Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating inthis contest. But we apprehend that many of your descendants may not have this luxury. For, as youknow, we are the dwellers of one of the most polluted
cities on earth. Pollution is everywhere, both inthe environment and in society and our lack of consciousness is simply aggravating the situation.

However, for the time being, we will consider only one type of pollution - the sound pollution. Theloudness or intensity level of sound is usually measured in decibels and sound having intensity level 130decibels or higher is considered painful. The intensity
level of normal conversation is 6065 decibels andthat of heavy traffic is 7080 decibels.

Consider the following city map where the edges refer to streets and the nodes refer to crossings.The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.

To get from crossing A to crossing G you may follow the following path: A-C-F-G. In that caseyou must be capable of tolerating sound intensity as high as 140 decibels. For the paths A-B-E-G,A-B-D-G and A-C-F-D-G you must tolerate respectively 90, 120 and
80 decibels of sound intensity.There are other paths, too. However, it is clear that A-C-F-D-G is the most comfortable path sinceit does not demand you to tolerate more than 80 decibels.

In this problem, given a city map you are required to determine the minimum sound intensity levelyou must be able to tolerate in order to get from a given crossing to another.

Input

The input may contain multiple test cases.

The first line of each test case contains three integers C(≤ 100), S(≤ 1000) and Q(≤ 10000) whereC indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 toC), S represents the number of streets and Q is the number
of queries.

Each of the next S lines contains three integers: c1, c2 and d indicating that the average soundintensity level on the street connecting the crossings c1 and c2 (c1 ̸= c2) is d decibels.

Each of the next Q lines contains two integers c1 and c2 (c1 ̸= c2) asking for the minimum soundintensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.

The input will terminate with three zeros form C, S and Q.

Output

For each test case in the input first output the test case number (starting from 1) as shown in thesample output. Then for each query in the input print a line giving the minimum sound intensity level(in decibels) you must be able to tolerate in order to
get from the first to the second crossing in thequery. If there exists no path between them just print the line “no path”.Print a blank line between two consecutive test cases.

Sample Input

7 9 3

1 2 50

1 3 60

2 4 120

2 5 90

3 6 50

4 6 80

4 7 70

5 7 40

6 7 140

1 7

2 6

6 2

7 6 3

1 2 50

1 3 60

2 4 120

3 6 50

4 6 80

5 7 40

7 5

1 7

2 4

0 0 0

Sample Output

Case #1

80

60

60

Case #2

40

no path

80

题目大意:输入一个C个点S条边(C <= 100,S <= 1000)的无向图,边权表示该路径上的噪声值。当噪声值太大时,耳膜可能会受到伤害,所以当你从某点到另一个点时,总是希望路上经过的最大噪声值最小。输入一些询问,每次询问两个点,输出这两点噪声值最小的路径上最大的噪声值。

解题思路:利用Floyd算法求解,因为要使最短路径上权值最大的边上的权值最小,所以要把加法改成max。

代码如下:

#include <bits/stdc++.h>
#define INF 1e9 + 5
using namespace std;
const int maxn = 105;
const int maxm = 1005;
int mp[maxn][maxn];
int m,n,q;
void init()
{
for(int i = 1;i <= n;i++)
for(int j = 1;j <= n;j++)
if(i == j) mp[i][j] = 0;
else mp[i][j] = INF;
}

void floyd()
{
for(int k = 1;k <= n;k++)
for(int i = 1;i <= n;i++)
for(int j = 1;j <= n;j++)
mp[i][j] = min(mp[i][j],max(mp[i][k],mp[k][j]));
}

int main(void)
{
int a,b,c;
int ncase = 0;
while(scanf("%d %d %d",&n,&m,&q) != EOF && n + m + q){
init();
if(ncase) printf("\n");
while(m--){
scanf("%d %d %d",&a,&b,&c);
mp[a][b] = mp[b][a] = c;
}
floyd();
printf("Case #%d\n",++ncase);
while(q--){
scanf("%d %d",&a,&b);
if(mp[a][b] == INF) printf("no path\n");
else printf("%d\n",mp[a][b]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVaOJ