您的位置:首页 > 其它

LightOJ1045 Digits of Factorial 求n的阶乘在k进制下的位数

2016-09-05 12:35 411 查看
Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

用换底公式去做即可,这样也能方便预处理节省时间。

logk( n! ) = log( n! ) / log( k )

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;
double a[1000005];
void p()
{
int i=0;
a[0]=log(1);
for(int i=1;i<1000005;i++){
a[i]=a[i-1]+log(i);
}
}
int main()
{std :: ios :: sync_with_stdio (false);
int t,n,k;
p();
scanf("%d",&t);
for(int i=1;i<=t;i++){
scanf("%d%d",&n,&k);
double ans=a
/log(k)+1;
printf("Case %d: %d\n",i,(int)ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: