您的位置:首页 > 其它

USACO 1.1.4 - Broken Necklace(DP)

2016-09-04 21:58 281 查看
Broken Necklace

You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

1 2                               1 2
r b b r                           b r r b
r         b                       b         b
r           r                     b           r
r             r                   w             r
b               r                 w               w
b                 b               r                 r
b                 b               b                 b
b                 b               r                 b
r               r                 b               r
b             r                   r             r
b           r                     r           r
r       r                         r       b
r b r                             r r w
Figure A                         Figure B
r red bead
b blue bead
w white bead


The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b’s and r’s, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.

Example

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration can include any of the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

PROGRAM NAME: beads

INPUT FORMAT

Line 1: N, the number of beads

Line 2: a string of N characters, each of which is r, b, or w

SAMPLE INPUT (file beads.in)

29

wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT

A single line containing the maximum of number of beads that can be collected from the supplied necklace.

SAMPLE OUTPUT (file beads.out)

11

OUTPUT EXPLANATION

Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.

题意:

给出一个项链,里面的颜色有红色,蓝色和白色.从一个点剪短,使得项链变成一个直线,从两头取珠子,取珠子的规则是颜色必须相同(白色可以看成任何一种颜色),问最多能取出多少个珠子.

解题思路:

刚开始是用模拟的方法去做,复杂度是O(n^2),用取模.

后来看网上题解用DP的方法,将字符串拼接起来,构成一个环,然后不断向后遍历,如果一样就使记录自增,同时维护一个state的变量,模拟断开的情况.

AC代码:

/*
ID:Reckful
LANG:C++
TASK:beads
*/
struct node
{
char name[15];
int give;
int receive;
}person[10];
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int main()
{
//freopen("beads.in","r",stdin);
//freopen("beads.out","w",stdout);
int n;
string s;
cin >> n >> s;
s += s;//字符串拼接
char c;
int state;
int res = 0;
for(int i = 0;i < n;i++)
{
c = (char)s[i];
if(c == 'w')    state = 0;
else            state = 1;
int j = i;
int current = 0;
while(state <= 2)
{
while(j < n+i && (s[j] == c || s[j] == 'w'))//保证不会超过总长度
{
current++;
j++;
}
state++;
c = s[j];
}
res = max(res,current);
}
printf("%d\n",res);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: