您的位置:首页 > 其它

HDU 3336 Count the string

2016-09-04 20:58 267 查看
Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: “abab”

The prefixes are: “a”, “ab”, “aba”, “abab”

For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1

4

abab

Sample Output

6

【题目大意】

要求求出所有前缀在字符串中的出现的次数之和。

【题目分析】

用f[i]来表示s[1]-s[i]的包含的全部的前缀的总次数。那么f[i]=f[next[i]]+1。这是显然成立的,对于这样的前缀,它同样也包含他的next指向的字符串的次数。所以需要进行累加操作,然后再对数列f求一个和就是答案了。

【代码】

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char a[200001];
int dp[200001],ne[200001];
int main()
{
int tt;
scanf("%d",&tt);
while (tt--)
{
dp[1]=1;ne[1]=0;
int l,ans=1;
scanf("%d%s",&l,a+1);
for (int i=2,j=0;i<=l;++i)
{
while (j&&a[j+1]!=a[i]) j=ne[j];
if (a[j+1]==a[i]) j++;
ne[i]=j;
if (j>0) dp[i]=(dp[j]+1)%10007;
else dp[i]=1;
(ans+=dp[i])%=10007;
}
cout<<ans<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu