您的位置:首页 > 编程语言 > Java开发

UVa455 Periodic Strings 周期串 (java版本)

2016-09-04 19:54 330 查看
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string “abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string “abc”. It also has
periods 6 (two repetitions of “abcabc”) and 12 (one repetition of “abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input
will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo 

Sample Output



分析:循环需要三重,仔细一点即可不出错。

import java.util.Scanner;

public class UVa455 {

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
String s = in.nextLine();
char[] c = s.toCharArray();
int k, m, n;
int l = s.length();
for (k = 1; k <= l; k++) {
Boolean f = true;
if (l % k == 0) {
for (m = 0; m < k; m++) {
for (n = 0; n < l / k - 1; n++) {
if (c[n * k + m] != c[n * k + k + m]) {
f = false;
}
}
}
} else
continue;
if (f) {
for (int i = 0; i < k; i++) {
System.out.print(c[i]);
}
break;
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: