您的位置:首页 > 其它

HDU 5831 Rikka with Parenthesis II

2016-09-04 16:11 411 查看
C - Rikka with Parenthesis II
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
5831

Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them: 

Correct parentheses sequences can be defined recursively as follows: 

1.The empty string "" is a correct sequence. 

2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence. 

3.If "X" is a correct sequence, then "(X)" is a correct sequence. 

Each correct parentheses sequence can be derived using the above rules. 

Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))". 

Now Yuta has a parentheses sequence $S$, and he wants Rikka to choose two different position $i,j$ and swap $S_i,S_j$. 

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation. 

It is too difficult for Rikka. Can you help her?

Input

The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100 

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

Output

For each testcase, print "Yes" or "No" in a line.

Sample Input

3
4
())(
4
()()
6
)))(((


Sample Output

Yes
Yes
No


题意:给出一堆‘(’和‘)’,必须在其中挑两个任意交换一次位置,问交换之后能否使整个序列的括号合法。

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
int n,m;
char a;
cin>>n;
while(n--)
{
cin>>m;
int k=m;
int l=0;
int e=0;
while(m--)
{
cin>>a;
if(a=='(')
l++;
else
{
if(l)
l--;
else
e++;
}
}
if(k==2&&e==0)
cout<<"NO"<<endl;
if(k==l&&e<=2)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: