您的位置:首页 > 产品设计 > UI/UE

POJ 2081——Recaman's Sequence

2016-09-04 12:43 330 查看
Recaman's Sequence

Time Limit: 3000MS Memory Limit: 60000K
Total Submissions: 22885 Accepted: 9881
Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m. 

The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 

Given k, your task is to calculate ak.
Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 

The last line contains an integer −1, which should not be processed.
Output

For each k given in the input, print one line containing ak to the output.
Sample Input
7
10000
-1

Sample Output
20
18658

Source
Shanghai 2004 Preliminary
题意:已知a[0]=0;如果a[m]-m>0并且a[m]-m在数列中没有出现过,则a[m]=a[m-1]-m,反之a[m]=a[m-1]+m.
解:直接打表操作,使用map来进行标记该数是否在数列中出现过。

#include<stdio.h>
#include<map>
#include<iostream>
using namespace std;

map<int ,int> m;

int a[500005];

void f()
{
a[0]=0;
m[a[0]]++;
for(int i=1;i<500005;i++){
int x=a[i-1]-i;
if(m[x]==0 && x>0){

a[i]=a[i-1]-i;
m[x]++;
}else {
a[i]=a[i-1]+i;
m[a[i]]++;
}
}
}
int main()
{
int n;
f();
while(~scanf("%d",&n) && n>=0){
printf("%d\n",a
);
}
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息