您的位置:首页 > 其它

HDU5007——Post Robot(2014 年 西安区域赛)

2016-09-04 12:28 363 查看


Post Robot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 193    Accepted Submission(s): 164


Problem Description

DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.

But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to
read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.

After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will
make a comment “MAI MAI MAI!”, and go on reading the post. 

In order to make it more funny, you, as a fan of
Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.

 

Input

A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters are case sensitive.

The size of the article does not exceed 8KB.

 

Output

Output should contains comments generated by your script, one per line.

 

Sample Input

Apple bananaiPad lemon ApplepiSony
233
Tim cook is doubi from Apple
iPhoneipad
iPhone30 is so biiiiiiig Microsoft
makes good App.

 

Sample Output

MAI MAI MAI!
MAI MAI MAI!
MAI MAI MAI!
SONY DAFA IS GOOD!
MAI MAI MAI!
MAI MAI MAI!
MAI MAI MAI!

 

Source

2014 ACM/ICPC Asia Regional Xi'an Online

题意:一个字符串,遇到 “Apple”, “iPhone”, “iPod”, “iPad” 就输出MAI MAI MAI!,遇到Sony则输出SONY
DAFA IS GOOD!。

解:字符串操作,水题,只需要模拟一下即可,注意区分大小写。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
char a[2000];
while(gets(a)){
int len=strlen(a);
for(int i=0;i<len;i++){
//Apple
if(a[i]=='A' && a[i+1]=='p' && a[i+2]=='p' && a[i+3]=='l' && a[i+4]=='e'){
printf("MAI MAI MAI!\n");
i=i+5;
}
//iPhone
if(a[i]=='i' && a[i+1]=='P' && a[i+2]=='h' && a[i+3]=='o' && a[i+4]=='n' && a[i+5]=='e'){
printf("MAI MAI MAI!\n");
i=i+6;
}
//iPod
if(a[i]=='i' && a[i+1]=='P' && a[i+2]=='o' && a[i+3]=='d'){
printf("MAI MAI MAI!\n");
i=i+4;
}
//
if(a[i]=='i' && a[i+1]=='P' && a[i+2]=='a' && a[i+3]=='d'){
printf("MAI MAI MAI!\n");
i=i+4;
}
//SONY
if(a[i]=='S' && a[i+1]=='o' && a[i+2]=='n' && a[i+3]=='y'){
printf("SONY DAFA IS GOOD!\n");
i=i+4;
}
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息