您的位置:首页 > 其它

POJ-3273 Monthly Expense(二分)

2016-09-03 15:11 239 查看
Monthly Expense

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22803 Accepted: 8930
Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need
to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more
consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M 

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400

Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling
gives a larger minimum monthly limit.
Source
USACO 2007 March Silver

大意:给你n和m的值,n代表n段天数,让你将这分成m段连续和,并且不重不漏,这m段连续和的最大值maxn,求最小的maxn。

思路:二分,可以将这个最大连续和作为分析对象,下界为n段天数的最大值,上界为n段的和,依此二分,从而寻找最优值。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n,m;
int a[100005];
bool Judge(int mid)
{
int sum = 0,num = 1;//查询每组上限为mid的情况下的组数
for(int i = 1;i <= n;i++)
{
if(sum + a[i] <= mid)
sum += a[i];
else
{
sum = a[i];
num++;
}
}
if(num > m)//组数偏大,说明mid偏小
return true;
else
return false;
}
int main()
{
cin >> n >> m;
int maxn = -1,sum = 0;
for(int i = 1;i <= n;i++)
{
scanf("%d",&a[i]);
maxn = max(maxn , a[i]);
sum += a[i];
}
int low = maxn,high = sum;
int mid = (low + high) / 2;
while(low < high)
{
if(Judge(mid))
low = mid + 1;
else
high = mid - 1;
mid = (low + high) / 2;
}
printf("%d\n",mid);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: